Managing Worksheets in Excel 2007

Bravo! Summer Institute 2010
# Table of Contents

Easy Worksheet Management .................................................................................. 4
   Sheet Tab ........................................................................................................ 4
   Changing Sheet Tab Color: ........................................................................... 4
   Rename Sheet Tab: ....................................................................................... 5
   Another way to Rename a Worksheet ......................................................... 5

Navigating between Workshops in a Workbook .................................................. 5

Charts ................................................................................................................ 6
   How to create a Chart ................................................................................... 6
      To Create a Chart ....................................................................................... 6

Creating Charts with F11 function key ............................................................... 8
   One Touch Excel Charts ............................................................................. 8

Modify the Chart if necessary: ........................................................................... 10
   Under Design Tab......................................................................................... 10
   Under the Layout tab .................................................................................... 10
   Under the Layout tab ................................................................................... 11

To Move a Chart ................................................................................................. 11
   Move the chart: ............................................................................................ 11
   Move the Chart to another sheet ............................................................... 11
   Move the Chart to a new chart sheet ........................................................ 12

Creating a Table ................................................................................................ 12

Remove Table header Filter ............................................................................... 15

Data Integrity ...................................................................................................... 17

Restricting Cell Entries to Certain Data Types.................................................. 17

Linking .............................................................................................................. 20
   Creating a Hyperlink to an Existing File or Webpage.............................. 20
   To create a hyperlink to an existing file or webpage: ................................ 20
   Creating a Hyperlink to a New Document (worksheet) ........................... 21
To create a hyperlink to a new document: ................................................................. 21
Accessing an external source using a Hyperlink ..................................................... 21
To Edit a Hyperlink ................................................................................................ 21
To Delete a Hyperlink ............................................................................................. 21
Paste Link ................................................................................................................ 22
Sorting and Filtering ............................................................................................... 23
Sorting ...................................................................................................................... 23
To Sort Data ............................................................................................................ 23
Filtering .................................................................................................................... 25
To filter data ............................................................................................................ 25
To Remove a Filter .................................................................................................. 27
Conditional Formatting ........................................................................................... 28
Color Scales ............................................................................................................. 28
To set the Conditional Formatting .......................................................................... 29
Easy Worksheet Management

Sheet Tab

Right-click on any sheet tab (Sheet1, Sheet2, etc.) for a shortcut menu of worksheet options. This is a quick way to rename, delete, insert, change color tab, move or copy and more.

Changing Sheet Tab Color:

To change the tab color, you right click the tab and select “Tab Color.” Select the desired color option.
**Rename Sheet Tab:**

To rename the tab, right click on the sheet tab to be rename and click on Rename.

![Screenshot of Rename Sheet Tab]

**Another way to Rename a Worksheet**

Double-click on any sheet tab (Sheet1, Sheet2, etc.) to highlight the sheet name. Type a new name and press **[Enter]**. Tip: avoid ALL CAPS which increases the width of the sheet name.

**Navigating between Workshops in a Workbook**

**OPEN ANY Excel file**

These keyboard shortcuts to toggle or cycle between worksheets:

- **Next worksheet:** [Ctrl] + [Page Down]
- **Previous worksheet:** [Ctrl] + [Page Up]
Charts

Charts are what we call graphs in math class. Charts are visual representations of worksheet data. Charts often make it easier to understand the data in a worksheet because users can easily pick out patterns and trends illustrated in the chart that are otherwise difficult to see.

How to create a Chart

To Create a Chart

1. Open an Excel spreadsheet with data.
2. If necessary arrange the data according to the chart to be created.
3. Highlight the desired data.
4. Select Chart Type

On the Insert Tab, in the Charts group, click the desired chart type and select the desired chart from the gallery, using the Insert Chart dialog box.
### Current Assets

<table>
<thead>
<tr>
<th>Description</th>
<th>2008</th>
<th>2007</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cash</td>
<td>301,124</td>
<td>318,497</td>
</tr>
<tr>
<td>Accounts Receivable</td>
<td>1,653,558</td>
<td>1,530,494</td>
</tr>
<tr>
<td>Inventories</td>
<td>546,171</td>
<td>520,144</td>
</tr>
<tr>
<td>Prepaid Expenses</td>
<td>13,102</td>
<td>23,025</td>
</tr>
<tr>
<td><strong>Total Current Assets</strong></td>
<td><strong>$4,909,083</strong></td>
<td><strong>$2,440,083</strong></td>
</tr>
</tbody>
</table>
Creating Charts with F11 function key

One Touch Excel Charts

If you ever need a chart in a hurry or you just want to check on certain trends in your data, you can create a chart in Excel with a single keystroke. There are only two steps to doing this:

1. Select the data you want to use in the chart.
2. Press the F11 key on the keyboard

The chart that is produced uses all the current defaults. If you haven’t changed any of the default settings, the chart you will get by pressing F11 is a Column Cluster Chart.

OPEN FILE THAT CONTAINS THE DATA TO CREATE A CHART

No need to Highlight Range

Place the mouse on a cell that would be consider part of the data to chart
Press F11 (the Function key at the top of the keyboard) after you have selected the cell.

Then you could modify the chart as necessary.
Modify the Chart if necessary:

Under Design Tab

CHANGE CHART LAYOUTS

CHANGE CHART STYLES

CHANGE CHART TYPE

MOVE CHART LOCATION

SWITCH CHART DATA

Under the Layout tab

INSERT PICTURES, SHAPES OR TEXTBOXES

ADD OR REMOVE LABELS

ADD OR REMOVE AXES

CHANGE BACKGROUND

CREATE ANALYSIS
Under the Layout tab

RESET TO MATCH STYLE
CHANGE SHAPE STYLES
WORDART STYLES
ARRANGE
CHANGE SIZE

To Move a Chart

1. In an Excel workbook containing a chart, click on the chart.
2. On the Ribbon, click the Chart Tools Design contextual tab
3. In the Location group, click Move Chart to display the Move Chart Dialog box.

Move the chart:

Move the Chart to another sheet
a. In the Move Chart Dialog box, click the Object In Option.
b. From the Object In drop down list, click the desired sheet.
c. Click OK to Move the chart to the desired sheet.
Move the Chart to a new chart sheet

a. In the Move Chart Dialog box, click the New Sheet Option.
b. In the New Sheet text box, type in the desired chart sheet name
c. Click OK to move the chart to the desired chart sheet.

---

Creating a Table

OPEN FILE THAT CONTAINS THE DATA TO CREATE A TABLE

Click on any cell within the List or if you just want a portion then highlight the portion of text you want.

Click on Insert tab

In the Tables group click on Table
Click OK

Use Table Styles – to format the table to different color
When the table is created the Row header becomes a filter.

Click on the down arrow of one the Row header,

i.e.: Category
You can perform Sorting and Filtering based on the data.

i.e.

Unselect all

Click on Excel

Figure 1: All data shown

Remove Table header Filter

- Click on Table
  - Under Table
    - Design Table
  - Click on Convert to Range

Figure 2: Data is Filter based on Category, for Excel
Click on yes. The header filter is removed. The data remains with color scheme.
Data Integrity

Restricting Cell Entries to Certain Data Types

1. Open the file that contains the data you wish to use restrict.
2. Select the Cells

3. On the Data Tab, in the Data tool group, click Data Validation.
4. On the Settings tab of the Data Validation dialog box, click on Whole number in the Allow box.
5. Type in a number for the Minimum box and another number in the Maximum box.
6. Click on the Error Alert tab. Type in text into the Title box.
7. Click in the message area box and type in the “error message”
8. Click on OK when finished.
9. To test that your validation rule see if it is working fine.
10. Enter a number greater or smaller than the range you specify.

   Depending on what you choose for the style you will get different results:
   - Stop
   - Warning
   - Information

It would **NOT** allow you to enter any other that is not within the range of accepted numbers. Retry to enter new number or cancel to keep original number.
It **WOULD** allow you to enter any other that is not within the range of accepted numbers by pressing Yes to continue. If you choose NO it would prompt you enter another number (cell highlighted in black). Click on Cancel to keep original number.

It **WOULD** allow you to enter any other that is not within the range of accepted numbers by pressing OK. Click on Cancel to keep original number.
Linking

Creating a Hyperlink to an Existing File or Webpage

To create a hyperlink to an existing file or webpage:

1. Select the cell in which you want to create the hyperlink.
2. On the Ribbon, on the Insert tab, in the Links group, click Hyperlink.
3. In the Link To section, click Existing File or Web Page.
4. In the Text To Display text box, enter a name for the hyperlink.
5. In the Address text box type the full name of the file (including the path) or choose the file by navigating to a desired location and selection. a file or webpage in the box under the Look In drop down list. Or for the webpage type in Website address.
6. Click on OK
Creating a Hyperlink to a New Document (worksheet)

To create a hyperlink to a new document:
1. Click on the cell in which you want to create the hyperlink.
2. On the Ribbon tab, on the Insert tab, in the Links group, click Hyperlink.
3. In the Link To section, click Create New Document to create a new document.
4. In the Text To Display text box, enter a name for the hyperlink to be displayed.
5. In the Name Of New Document text box, enter a name for the new document.
6. In the When To Edit section, select either Edit The New Document Now or Edit The New Document Later to specify if you want to edit the document now or later.
7. Click on OK to create the hyperlink

Accessing an external source using a Hyperlink
1. In the cell with the hyperlink, move the mouse pointer over the hyperlink to view details regarding the location of the external resource.
2. Move the mouse over the hyperlink until it becomes a hand and then click to open linked file/webpage.

To Edit a Hyperlink
1. Right click the cell with the hyperlink and click on Edit hyperlink.
2. In the Edit Hyperlink dialog box, make the necessary changes.
3. Click OK to save the changes.

To Delete a Hyperlink
1. Right click the cell with the hyperlink and click on Remove hyperlink.
2. Or select the cell with hyperlink and press Delete.
Paste Link

1. Highlight the range of cells you wish to use as Paste Link
2. Click on Copy
3. Navigate to new location.
4. Click on the Home tab.
5. In the Clipboard group
6. Click the Down arrow under Paste
7. Click on Paste Special

Click on Paste Link

Whatever is changed in the original data affects the paste link data.
Sorting and Filtering

Sorting
Sorting Data in a Spreadsheet: You may have data in your worksheet that you would like to rearrange and display in a different sequence. Sorting is a method of viewing data that arranges all the data into a specific order. Data can be sorted ascending order or descending order based on the alphabet or numeric information. Data can be sorted on a single criterion or multiple criteria.

To Sort Data
1. Highlight the range you want to sort, including column headings.
2. On the Data tab, in the Sort & Filter group, click on Sort.

3. In the Sort dialog box, from the Sort By drop-down list, select the column you want to sort by.
4. If need be, from the Sort On dropdown list, click the item you want to sort on:
   - Values
   - Cell Color
   - Font Color
   - Icon Color

5. If necessary, from the Order drop down list, select the ordering you desire.
6. If desired, click Add Level to add another sort level for a multiple level sort.
7. If necessary, from the Then By drop down list, select the column you want to sort by.
8. If necessary, select the items you want to sort on and select the ordering you desire.
Filtering
A filter is a method of viewing data that shows only the data that meets a criterion. Data can be filtered on a single criterion or multiple criteria using the alphabet and numeric information. Drop down arrows for each column heading is displayed. What data does not meet the filter criteria, the entire row is hidden. A filter can rearrange the data in the worksheet. Filtered data is restored to its original format by removing the filter.

To filter data
1. Highlight the data you want to filter, including column headings.
2. On the Data tab, in the Sort & Filter group, click on Filter.
3. On the column you want to use as a filter criterion, click the filter drop down list button.
4. Select the appropriate filter from the list.
5. If necessary, select additional filtering criteria.

6. Click on OK.
To Remove a Filter

1. On the column from which you want to remove the filter criterion, click the Filter drop down list button
2. Click the Clear Filter From option.
Conditional Formatting

Conditional formatting is helpful and makes it easier to highlight interesting cells or ranges of cells, to emphasize unusual values, and to help visualize data by using data bars, color scales, and icon sets. A conditional format changes the appearance of a cell range based on a condition (or criteria). If the condition is true, the cell range is formatted based on that condition; if the conditional is false, the cell range is not formatted based on that condition.

Color Scales

Conditional Formatting allows you to change the appearance of a cell, depending on certain conditions. In the example below – the Color Scales will be applied to the Overall Averages based on the Overall Average for each student.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Maths</td>
<td>76</td>
<td>89</td>
<td>43</td>
<td>48</td>
<td>51</td>
<td>76</td>
<td>87</td>
<td>56</td>
</tr>
<tr>
<td>3</td>
<td>English</td>
<td>55</td>
<td>85</td>
<td>78</td>
<td>61</td>
<td>47</td>
<td>87</td>
<td>91</td>
<td>73</td>
</tr>
<tr>
<td>4</td>
<td>Science</td>
<td>65</td>
<td>82</td>
<td>39</td>
<td>58</td>
<td>52</td>
<td>65</td>
<td>57</td>
<td>45</td>
</tr>
<tr>
<td>5</td>
<td>History</td>
<td>45</td>
<td>91</td>
<td>56</td>
<td>72</td>
<td>49</td>
<td>56</td>
<td>78</td>
<td>56</td>
</tr>
<tr>
<td>6</td>
<td>Geography</td>
<td>51</td>
<td>84</td>
<td>54</td>
<td>64</td>
<td>47</td>
<td>64</td>
<td>67</td>
<td>67</td>
</tr>
<tr>
<td>7</td>
<td>Art</td>
<td>43</td>
<td>63</td>
<td>49</td>
<td>62</td>
<td>39</td>
<td>89</td>
<td>64</td>
<td>63</td>
</tr>
<tr>
<td>8</td>
<td>Computer Studies</td>
<td>63</td>
<td>95</td>
<td>45</td>
<td>59</td>
<td>41</td>
<td>92</td>
<td>89</td>
<td>52</td>
</tr>
<tr>
<td>9</td>
<td>French</td>
<td>35</td>
<td>91</td>
<td>65</td>
<td>26</td>
<td>28</td>
<td>51</td>
<td>92</td>
<td>56</td>
</tr>
<tr>
<td>10</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Overall Average</td>
<td>54.13</td>
<td>85.00</td>
<td>53.63</td>
<td>56.25</td>
<td>44.25</td>
<td>72.50</td>
<td>78.13</td>
<td>58.50</td>
</tr>
</tbody>
</table>

- The Highlight the cells with Overall Average, which is cells B11 to I11

The Overall Averages range from 44 to 85. A color each grade will be applied, depending on a scale. A different color will apply to the following grades:

- 50 and below
- 51 to 60
- 61 to 70
- 71 to 80
- 81 and above

This will result in five different bands and a color for each.
To set the Conditional Formatting in Excel 2007, do the following:

- With your Overall Averages highlighted, click on the Home tab.
- In the Styles group, click on Conditional Formatting

The Conditional Formatting menu gives you various options. Select one of these and Excel will color the cell backgrounds for you:

This is not quite what we were looking for, though. We would like to choose our own values.

1. Click on Conditional Formatting in the Styles on the Home tab.
2. Click on the Color Scale
3. Click on More Rules, from the Color Scales submenu.
   - You'll see the following rather complex dialogue box:
4. Click the second option, **Format only cells that contain**. This will allow you to set up your own values. The dialog box changes to this:
5. Under the **heading Edit the Rule Description.**

It says Cell Value and between blank text box and blank text box. This is the one we want. Type in a value for the two boxes that are currently blank in the image on page above.

6. Then click the Format button to choose a color.

So for example type 0 in the first box and 50 in the second one:

![Image of Edit the Rule Description](image)

7. Then click the Format button.

A dialog box will appear. If you choose the color from this option it will only format the Text for the color of choice.

8. **Click on the Fill** tab and choose a color. This will fill in the back ground of the cell.
9. Click OK and notice the preview under Edit the Rule Description:

![Image of Edit the Rule Description](image)

_The Preview is showing the color that selected. "If the Cell Value is between 0 and 50 then color the cell Red"._

10. Click OK on this dialog box to see the spreadsheet.

    Notice one of the cells has turned Red.
To format the remaining cells, click on Conditional Formatting on the Styles group again. From the menu, click on Manage Rules:

A complex dialog box appears

The first rule is already there - Cell Value Between 0 a….

11. The next step is clicking on New rules.
12. Click the New rule button then.
   - The exact same dialog box used to set up the first rule pops up.

13. Click the second option, **Format only cells that contain**.

14. Set a new color for the next scores - 51 to 60.

15. **Click on the Fill** tab and choose a color.

16. Click on OK to get back to the Rules Manager dialog box. It should now look something like this one:

   ![Conditional Formatting Rules Manager](image)

17. Repeat steps to do the remaining ranges. The scores are the following:

   - 61 to 70
   - 71 to 80
   - 81 and above

After completing the remaining ranges the dialog box will have five colors:
The Overall Averages will then look something like this:

Formatting the spreadsheet in this way using Scale Color allows one to see at a glance relevant information. In the spreadsheet above, it's clear to see who is failing - by looking for the red cells!