Managing Worksheets in Excel 2007
Bravo! Summer Institute 2010
Table of Contents
Using functions – Left, Right, MID ............................................................. 3
To Show Formulas .......................................................................................... 3
To Hide a sheet ............................................................................................... 4
To unhide the sheet ......................................................................................... 7
Converting Uppercase Letters to Lowercase ............................................... 7
Grouping Worksheets together ..................................................................... 9
  Grouping Sheets .......................................................................................... 9
    Grouping Sheets using the Select All Sheets option ................................ 9
    Grouping Sheets using the using the Ctrl Key option ............................. 9
Transpose ...................................................................................................... 11
Freeze Panes .................................................................................................. 12
  Freeze Top Row .......................................................................................... 12
Freeze First Column ...................................................................................... 13
Pivot Tables .................................................................................................... 18
  What is a Pivot Table .................................................................................. 18
To Create a Pivot Table .................................................................................. 18
Create a Pivot Chart ....................................................................................... 24
To create a PivotChart report ........................................................................ 24
Using functions – Left, Right, MID

Type in Cell B1: 111-22-3333

Formula

=LEFT(b1,3)

Result

111

Formula

=RIGHT(b1,4)

Result

3333

Formula

= MID(b1,5,2)

Start number, how many characters

Result

22

To Show Formulas

To quickly show all formulas in your Excel spreadsheet hold down the CONTROL (Ctrl) key on the keyboard and press the grave accent key also known as the Tilde (`).

This key is located next to the #1 key on the top left corner of the keyboard and looks like a backwards apostrophe.
Or

Click on the Formulas tab, in the Formula Auditing group, click on Show Formulas.

To Hide a sheet

1. Click on the Sheet you want to hide.
2. On the Home tab, in the Cells group click on "Hide & Unhide" from the Format drop down menu as shown below.
Or Right click on the Sheet tab and click on Hide.

{The sheet disappears}

At this point the sheet is not complete hidden because all a user has to do is right click on the sheet tab and click on “Unhide”. So to permanently hide the sheet until you wish to view again you need to do some additional steps.

1. After hiding the sheet.
2. Then click on the Review tab.
3. Click on Protect Workbook.
4. Click on Protect Structure and Windows.
Protect Structure and Windows (popup window appears)

![Protect Structure and Windows window]

5. Leave the check mark in Structure.
6. Type in a password (however if you should forget the password then you will not be able to unhide that sheet.
7. Click OK.
   You will be prompted to retype the same password as confirmation.
8. Click Ok.
   At this point the sheet is hidden and cannot be unhide without using the password - Notice when you right click on the Sheet tab that “Unhide” is grayed out – non-operational.
To unhide the sheet

1. Click on the Review tab.
2. Click on Protect Workbook.
3. Click on Protect Structure and Window.
4. Type in the password.
5. Right click on the sheet tab and then click on Unhide.

Should wish to hide it again – repeat steps from “How to Hide a sheet”.

Converting Uppercase Letters to Lowercase

Use the LOWER function to convert all uppercase letters in a text string to lowercase.
Use the UPPPER function to convert all lowercase letters in a text string to uppercase.
Use the PROPER function to convert text to proper case where the first letter of each word is capitalized.
Examples: All Examples are type in Cell A1 and the function in different Cell.

Typed in as uppercase: JOHN JAY COLLEGE

The function: to convert text to all lowercase

=LOWER(A1)

Result: john jay college

------------------------------------------------------------------------------------------------------------------------

Typed in as lowercase: john jay college

The function: to convert text to all uppercase

=UPPER(A1)

Result: JOHN JAY COLLEGE

------------------------------------------------------------------------------------------------------------------------

Typed in as lowercase: john jay college

The function: to convert to proper case (grammatically the first letter of each word is capitalized)

=PROPER(A1)

Result: John Jay College

------------------------------------------------------------------------------------------------------------------------
Grouping Worksheets together

Grouping Sheets

Grouping the sheets in your workbook together is a great feature. Although there are several benefits of using this function, it is very important to ungroup sheets after entering the data you wish each sheet to contain. Because if you don’t, what you do in any of the group sheets affects the others.

The reason for ungrouping the sheets is when all sheets are selected, whatever you do to one sheet affects all the sheets. That is, deleting a cell on the first sheet will delete the same cell on all the sheets.

You can use this feature to your advantage, for example, when developing a new workbook. Suppose you’d like to put some standard text headings on all the sheets in your workbook. All you have to do is group together the sheets, enter the text on the first sheet, and then ungroup the sheets. The text you entered will appear in the same place on all the sheets in the workbook.

Grouping Sheets using the Select All Sheets option

For example, you want to check the spelling in all the sheets of a workbook:

1. **To Group sheets together**: Right-click on any sheet tab, click on Select All Sheets.
2. Click on the Review tab, in the Proofing group, click on Spelling.
3. **To Ungroup sheets**: Right-click on any sheet tab, Choose Ungroup Sheets.

OR

Grouping Sheets using the using the Ctrl Key option

You may click on selective Sheet tabs or all tabs

1. Click on Sheet1, while holding down the Ctrl key click on Sheet2 and Sheet3. Release the mouse and the Ctrl key once finished selecting tabs.
2. Begin typing in your information.
3. Don’t forget to ungroup your sheets once finished.
4. Click on each sheet that was group together or use Step 3 from **Grouping Sheets using the Select All Sheets option.**

In the Title bar of the worksheet would display the name of the file and the Group which indicates at least 2 or more sheets have been group together. After you ungroup the sheets the word Group will no longer display.
**Transpose**
Use Transpose if you want to transpose your columns to rows or rows to columns.

**OPEN FILE THAT CONTAINS DATA TO TRANSPOSE**

1. Highlight text.
2. Click on Copy on the Home tab in the Clipboard group.
3. Click the down arrow on Paste in the Clipboard group.
4. Click Paste Special.
5. Click on Transpose.
   Or
6. Right click with the Mouse.
7. Click on Paste Special.
8. Click on Transpose.

![ Paste Special dialog box with Transpose option highlighted. ]

Figure 1: BEFORE DATA WAS TRANSPOSE.

![ Transposed data before and after. ]

Figure 2: AFTER THE DATA IS TRANSPOSE
Freeze Panes

**OPEN FILE THAT CONTAINS DATA TO FREEZE PANES**

**Freeze Top Row**

The most common use of Excel’s Freeze Pane feature is to freeze the top row that contains the column headings in the spreadsheet.

**To freeze the top row**

Clicking on the View tab, in the Window group, click on Freeze Panes and then click on Freeze Top Row.
Notice that Excel indicates the freezing of the top row with a solid black line between rows 1 and 2. You should also notice that as you scroll down the spreadsheet, the top row stays where it is while all of the other rows scroll.

To unfreeze the top row

Clicking on the View tab (if not already on that tab), in the Window group click on Freeze Panes.

Click on the Unfreeze Panes button.

Freeze First Column

Not only can freeze the top row, you can also freeze the first column in the same way.

To freeze the First Column

Clicking on the View tab, in the Window group, click on Freeze Panes and then click on Freeze First Column.
Notice, again, that Excel indicates the frozen pane with a black line but this time you will find it between columns 1 and 2. (in the example on previous page between A and B) Also notice that as you scroll left and right, the first column stays where it is while all of the other columns scroll.

**To unfreeze the First Column**, follow the same steps you used to “To unfreeze the top row”.

You can even freeze a combination of both rows and columns. You can actually freeze any cells you want to create custom panes.

**To Freeze both rows and columns and create a custom frozen pane**

Click on any cell in your spreadsheet.

Then clicking on the View tab, in the Window group, click on Freeze Panes and then click on Freeze Panes.

![Excel screenshot](image)

You will notice that Excel froze the cells to the left and above the active cell. Using this method, you can simultaneously freeze both the rows and columns you
want. Freezing panes in Excel can help make large spreadsheets more manageable by eliminating the need to constantly scroll to the top or left to see the headings of the cells in which you are working.

**To unfreeze the both rows and columns**, follow the same steps you used to “To unfreeze the top row”

If a worksheet extents over more than one page, you can print row and column headings or labels (also called print titles) on every page to ensure that the data is properly labeled.

To print header row or first row on each and every page

Click on the Layout tab, in Page Setup group, click on Print Titles.

![Excel screenshot showing Print Titles dialog box with specified rows and columns to repeat on each printed page.](image)
Click the collapse button (red arrow icon) next to Rows to repeat at top.

Use the mouse to select the first row or the row that you want to repeat in each and every page that is printed.
Click the collapse button (red arrow icon) next to Rows to repeat at top to return back to Page Setup window.
**Pivot Tables**

*What is a Pivot Table?*

A pivot table creates an interactive summary from many records.

For example, you may have hundreds of invoice entries in a list on your worksheet. A pivot table can total the invoices by customer, product or date. You create the pivot table by using a wizard -- no need for complicated formulas.

You can quickly rearrange the information in the pivot table by dragging the buttons to a new position.

**To Create a Pivot Table**

*Open file that contains data to a pivot table*

Select any cell in the source data table.

On the Ribbon, click the Insert tab.

In the Tables group, click PivotTable.
The Create Pivot Table pop-up window appears.

Depending if you wish to place the Pivot Table report in New Worksheet or in the Existing Worksheet, click the desired option.

Click OK once finished.
Using the drag and drop method – hold the mouse and click on Field name from “Choose fields to add to report” and drag it to one of the quadrants: **Report Filter**, **Column Labels**, **Row Labels** and **Values**.
Figure 2: Pivot Table is now complete. You may the Filter to change the data to display. As well as you can move the fields around by dragging and dropping.
Figure 3: Same file. Different outcome by moving the field names around
If you don’t want to include a field in the Pivot table uncheck from the Field list window.

Click on the X to close the Field list window.

To return back to your original data, click on the sheet tab that contains the data (i.e. sheet1).
Create a Pivot Chart

To create a PivotChart report

Select the PivotTable report that contains the data you want to convert to a PivotChart report.

On the PivotTable Tools tab, click the Options tab.

Click on PivotChart.

Choose Chart type.

Click OK.
Close the PivotChart Filter pane if necessary by clicking on the X to close the window.

Then you may format the chart just would any other chart.