Managing formulas and Spreadsheets in Excel 2010

Bravo! Employee Summer Institute 2011
# Table of Contents

Performing Calculations .................................................................................................................. 3  
Functions ............................................................................................................................................. 3  
  Working with Mixed References ........................................................................................................ 4  
  Absolute References ........................................................................................................................... 4  
    Definition ......................................................................................................................................... 4  
  Mixed References .............................................................................................................................. 5  
    Definition ......................................................................................................................................... 5  
How to construct an Absolute Cell Reference .................................................................................... 5  
Relative References ............................................................................................................................. 6  
Creating a Table .................................................................................................................................. 7  
  Creating Tables in Excel 2010 ........................................................................................................... 7  
  Properties of Excel Tables ................................................................................................................ 9  
  Deleting an Excel Table ..................................................................................................................... 9  
Charts .................................................................................................................................................... 10  
  Definition of a few types of Charts ................................................................................................... 10  
Identifying the Parts of a Chart .......................................................................................................... 11  
To Create a Chart: ............................................................................................................................... 12  
Chart Tools .......................................................................................................................................... 14  
To Switch Row and Column Data: ..................................................................................................... 15  
To Change the Chart Layout: ............................................................................................................ 16  
To Change the Chart Style: .................................................................................................................. 18  
To Move the Chart to a Different Worksheet: ....................................................................................... 19
Performing Calculations

Formulas Tab

Functions
Typing the cell references for 15 or 20 cells in a calculation would be overwhelming, but Excel 2010 makes it easy to handle complex calculations. To create a new calculation, click the Formulas tab and then, in the Function Library group, click Insert Function. The Insert Function dialog box appears, with a list of functions, or predefined formulas, from which you can choose. The following table describes some of the most useful functions in the list.

<table>
<thead>
<tr>
<th>FUNCTION</th>
<th>DESCRIPTION</th>
</tr>
</thead>
<tbody>
<tr>
<td>SUM</td>
<td>Finds the sum of the numbers in the specified cells</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>Finds the average of the numbers in the specified cells</td>
</tr>
<tr>
<td>MAX</td>
<td>Finds the largest value in the specified cells</td>
</tr>
<tr>
<td>MIN</td>
<td>Finds the smallest value in the specified cells</td>
</tr>
</tbody>
</table>
Working with Mixed References

Absolute References

Definition

An absolute reference is a cell reference in a formula that doesn’t change when the formula is copied from one position to another to reflect the new position. Absolute references are used in formulas to refer to the values in cells that need to be constant while performing calculations. All absolute references contain a dollar sign ( $ ) before the column and row heading in the cell reference.

One quick way to change a cell reference from relative to absolute is to select the cell reference on the formula bar and then press F4 key in the keyboard. Pressing F4 cycles a cell reference through the four possible types of references:

- Relative columns and rows (C4)
- Absolute columns and rows ($C$4)
- Relative columns and absolute rows (C$4)
- Absolute columns and relative rows ($C4)
Mixed References

Definition
A mixed reference is a cell reference that contains both an absolute and a relative reference. When the formula is copied from one place to another, the relative reference in the mixed reference changes, while the absolute reference does not change. Mixed references contain either an absolute column and relative row or an absolute row and relative column.

How to construct an Absolute Cell Reference

In Excel, we create an absolute cell reference by using a “$” before each letter and number. The formula for C1 then becomes

=$A$1+$B$2

Copying that formula to C2 retains those absolute references and we find that C2 also uses

=$A$1+$B$2.

You can also mix an absolute with relative references like this: A$1. Here the row is fixed at one, but the column remains relative.
In order to maintain accurate formulas, it is necessary to understand how cell references respond when you copy or fill them to new cells in the worksheet.

Excel will interpret cell references as either **relative** or **absolute**. By default, cell references are **relative references**. When copied or filled, they change based on the relative position of rows and columns. If you copy formula (=A1+B1) into row 2, the formula will change to become (=A2+B2).

**Absolute references**, on the other hand, do not change when they are copied or filled and are used when you want the values to stay the same.

### Relative References

Relative references can save you time when you are repeating the same kind of calculation across multiple rows or columns.

<table>
<thead>
<tr>
<th>Reference Type</th>
<th>Formula</th>
<th>What Happens After Copying the Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relative</td>
<td>=A1</td>
<td>Both the column letter A and the row number 1 can change.</td>
</tr>
<tr>
<td>Absolute</td>
<td>=$A$1</td>
<td>The column letter A and the row number 1 does not change.</td>
</tr>
<tr>
<td>Mixed</td>
<td>=$A$1</td>
<td>The column letter A does not change. The row number 1 can change.</td>
</tr>
<tr>
<td>Mixed</td>
<td>=A$1</td>
<td>The column letter A can change. The row number 1 does not change.</td>
</tr>
</tbody>
</table>
Creating a Table

A table is a range of cells that hold data, with each row corresponding to a single occurrence of an entity. You can format the table and/or filter the table columns. Usually there is an initial row of text headings that describe the columns of data. For example, you might have rows and rows of employee data with the following column headings:

- Last Name
- First Name
- Department
- Office Location
- Extension
- Bonus

Creating Tables in Excel 2010

Click on any cell within the range you want to convert into a table.

Then click Insert Tab.

In the Tables group click on Table.

If your data has headers, make sure to check the My table has headers box in the create table window, and then those headers will be used.

Note: No need to select the entire range of cells: Excel can identify the limits of the data and also identify the headings. The following is an example of tabular data before we convert it into a table.
Managing formulas and Spreadsheets in Excel 2010

After the table is converted, it looks like this:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Last Name</td>
<td>First Name</td>
<td>Department</td>
<td>Office Location</td>
<td>Extension</td>
</tr>
<tr>
<td>2</td>
<td>Barry</td>
<td>Angela</td>
<td>Accounting</td>
<td>3g</td>
<td>2667</td>
</tr>
<tr>
<td>3</td>
<td>Boller</td>
<td>Mary</td>
<td>Development</td>
<td>8d</td>
<td>2544</td>
</tr>
<tr>
<td>4</td>
<td>Chaffee</td>
<td>Adam</td>
<td>Accounting</td>
<td>10a</td>
<td>2678</td>
</tr>
<tr>
<td>5</td>
<td>Chase</td>
<td>Fred</td>
<td>Human Resources</td>
<td>8b</td>
<td>2511</td>
</tr>
<tr>
<td>6</td>
<td>Chu</td>
<td>Laurie</td>
<td>Human Resources</td>
<td>2d</td>
<td>2053</td>
</tr>
<tr>
<td>7</td>
<td>Chung</td>
<td>Bob</td>
<td>Development</td>
<td>8e</td>
<td>2547</td>
</tr>
<tr>
<td>8</td>
<td>Clark</td>
<td>Anna</td>
<td>Engineering</td>
<td>11c</td>
<td>2770</td>
</tr>
<tr>
<td>9</td>
<td>Clark</td>
<td>John</td>
<td>Development</td>
<td>2c</td>
<td>2546</td>
</tr>
<tr>
<td>10</td>
<td>Clarke</td>
<td>Joe</td>
<td>Engineering</td>
<td>11d</td>
<td>2776</td>
</tr>
<tr>
<td>11</td>
<td>Cole</td>
<td>Daniel</td>
<td>Accounting</td>
<td>4c</td>
<td>2056</td>
</tr>
<tr>
<td>12</td>
<td>Comuntzis</td>
<td>Mark</td>
<td>Executive</td>
<td>6a</td>
<td>2089</td>
</tr>
<tr>
<td>13</td>
<td>Decker</td>
<td>Erica</td>
<td>Accounting</td>
<td>9e</td>
<td>2665</td>
</tr>
<tr>
<td>14</td>
<td>Sanchez</td>
<td>Barbara</td>
<td>Tech. Support</td>
<td>2e</td>
<td>2099</td>
</tr>
<tr>
<td>15</td>
<td>Donnell</td>
<td>Susan</td>
<td>Accounting</td>
<td>3d</td>
<td>2688</td>
</tr>
<tr>
<td>16</td>
<td>Ellis</td>
<td>Janet</td>
<td>Customer Service</td>
<td>2f</td>
<td>2109</td>
</tr>
<tr>
<td>17</td>
<td>Fern</td>
<td>Elizabeth</td>
<td>Accounting</td>
<td>10b</td>
<td>2700</td>
</tr>
<tr>
<td>18</td>
<td>Ferris</td>
<td>Jim</td>
<td>Human Resources</td>
<td>3c</td>
<td>2478</td>
</tr>
<tr>
<td>19</td>
<td>Filosa</td>
<td>Alexandra</td>
<td>Facilities</td>
<td>6b</td>
<td>2110</td>
</tr>
<tr>
<td>20</td>
<td>Flanders</td>
<td>Elizabeth</td>
<td>Engineering</td>
<td>1a</td>
<td>2046</td>
</tr>
<tr>
<td>21</td>
<td>Grant</td>
<td>Sabrina</td>
<td>Development</td>
<td>12d</td>
<td>2967</td>
</tr>
</tbody>
</table>

Page 8 of 19
Managing formulas and Spreadsheets in Excel 2010

If you create a table this way, it is given default formatting that you can change using the Table Styles on the Design tab that appears when the table is selected.

*Alternatively, you can select a style when you create the table.*

To do this, activate any cell in the range of the table.

Click on the Home tab

In the Styles group click on Format as Table.

Choose a style from the panel that opens and your table will be created with that style.

**Properties of Excel Tables**

The main things to notice about tables are:

- When any cell in the table becomes active, the Table Tools contextual tab is displayed.
- Each column heading contains a drop down list that you can use to sort or filter the data in that column.
- If you scroll so far down the table that the column headings disappear, the letters that mark the column headings in the worksheet are replaced with the table’s column headings.
- The cells have background colors to enhance readability.

**Deleting an Excel Table**

If wanted to change the data in its original form (i.e. not in a table), you can convert it back to a range of cells.

- Click anywhere in the table and then on the Table Tools tab click Design tab
- In the Tools group click on Convert To Range.
- Once the data is converted back to a range, the table features are no longer available.

Note that the formatting that was applied to the table is still present.

If you want to delete the table and all its data, select the table and press the delete key.
Charts

A chart is a tool you can use in Excel to communicate your data graphically. Charts allow your audience to see the meaning behind the numbers, and they make showing comparisons and trends a lot easier. In this lesson, you will learn how to insert charts and modify them so that they communicate information effectively.

Charts

Excel workbooks can contain a lot of data, and that data can often be difficult to interpret. For example, where are the highest and lowest values? Are the numbers increasing or decreasing?

The answers to questions like these can become much clearer when the data is represented as a chart. Excel has many different types of charts, so you can choose one that most effectively represents the data.

Definition of a few types of Charts

<table>
<thead>
<tr>
<th>Type of Charts</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pie Chart</td>
<td>are used to show percentages. For example, a pie chart could be used to show what percentage of your total number of students who own a Smartphone.</td>
</tr>
<tr>
<td>Column Charts</td>
<td>are used to show comparisons between items of data. Each column in the chart represents the value of one item of data. An example of this would be to compare the number of students who own a Smartphone compare to number of student who do not have a Smartphone.</td>
</tr>
<tr>
<td>Bar Charts</td>
<td>are very similar to column charts, except they run horizontally on the page instead of vertically like column charts.</td>
</tr>
<tr>
<td>Line Charts</td>
<td>are used to show trends over time. Each line in the graph shows the changes in the value of one item of data. For example you could show changes in the stock market.</td>
</tr>
</tbody>
</table>

Example of Exploded Pie

<table>
<thead>
<tr>
<th>BUDGET</th>
</tr>
</thead>
<tbody>
<tr>
<td>Human Resources</td>
</tr>
<tr>
<td>Administration</td>
</tr>
<tr>
<td>Sales</td>
</tr>
<tr>
<td>Marketing</td>
</tr>
<tr>
<td>Finance</td>
</tr>
</tbody>
</table>
Identifying the Parts of a Chart

1. Title
2. Data Series
3. Vertical Axis
4. Horizontal Axis
5. Legend
To Create a Chart:

1. Select the **cells** that you want to chart, including the **column titles** and the **row labels**. These cells will be the **source data** for the chart.

![Excel spreadsheet](image)

**Selecting cells**

2. Click the **Insert** tab.
3. In the **Charts** group, select the desired **chart category** (Column, for example).

![Inserting a chart](image)

**Selecting the Column category**
4. Select the desired **chart type** from the drop-down menu (Clustered Column, for example).

```
<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Sales</td>
<td>BOOKS</td>
</tr>
<tr>
<td>3</td>
<td>Jan</td>
<td>$350</td>
</tr>
<tr>
<td>4</td>
<td>Feb</td>
<td>$525</td>
</tr>
<tr>
<td>5</td>
<td>Mar</td>
<td>$600</td>
</tr>
<tr>
<td>6</td>
<td>Apr</td>
<td>$650</td>
</tr>
<tr>
<td>7</td>
<td>May</td>
<td>$600</td>
</tr>
<tr>
<td>8</td>
<td>June</td>
<td>$525</td>
</tr>
<tr>
<td>9</td>
<td>July</td>
<td>$775</td>
</tr>
<tr>
<td>10</td>
<td>Aug</td>
<td>$775</td>
</tr>
<tr>
<td>11</td>
<td>Sept</td>
<td>$550</td>
</tr>
<tr>
<td>12</td>
<td>Oct</td>
<td>$775</td>
</tr>
<tr>
<td>13</td>
<td>Nov</td>
<td>$850</td>
</tr>
<tr>
<td>14</td>
<td>Dec</td>
<td>$650</td>
</tr>
</tbody>
</table>
```

Selecting a chart type

5. The chart will appear in the worksheet.
Chart Tools

Once you insert a chart, a set of Chart Tools, arranged into three tabs, will appear on the Ribbon. These are only visible when the chart is selected. You can use these three tabs to modify your chart.

To Change the Chart Type:

1. From the Design tab, click the Change Chart Type command. A dialog box appears.

2. Select the desired chart type and click OK.

Selecting a chart type
Managing formulas and Spreadsheets in Excel 2010

To Switch Row and Column Data:

Sometimes when you create a chart, the data may not be grouped the way you want it to be. In the clustered column chart below, the Book Sales statistics are grouped by Fiction/Non-Fiction, with a column for each year. However, you can also switch the row and column data so that the chart will group the statistics by year, with columns for Fiction and Non-Fiction. In both cases, the chart contains the same data; it’s just organized differently.

Book Sales, grouped by Fiction/Non-Fiction

1. Select the chart.
2. From the Design tab, select the Switch Row/Column command.
Managing formulas and Spreadsheets in Excel 2010

3. The chart will then readjust.

![Book sales, grouped by year](image)

*Book sales, grouped by year*

**To Change the Chart Layout:**

1. Select the **Design** tab.
2. Click the **More** drop-down arrow in the **Chart Layouts** group to see all of the available layouts.

![Viewing all of the chart layouts](image)
Managing formulas and Spreadsheets in Excel 2010

3. Select the desired layout.

Selecting a chart layout

4. The chart will update to reflect the new layout.

*The updated layout*

Some layouts include **chart titles**, **axes**, or **legend labels**. To change them, just place the **insertion point** in the text and begin typing.
To Change the Chart Style:

1. Select the Design tab.
2. Click the More drop-down arrow in the Chart Styles group to see all of the available styles.
3. Select the desired style.
4. The chart will update to reflect the new style.
To Move the Chart to a Different Worksheet:

1. Select the **Design** tab.
2. Click the **Move Chart** command. A dialog box appears. The current location of the chart is selected.

![The Move Chart command](image)

3. Select the desired location for the chart (i.e. choose an existing worksheet, or select New Sheet and name it).

![Selecting a different worksheet for the chart](image)

4. Click **OK**. The chart will appear in the new location.